about summary refs log tree commit diff
path: root/nix/lib/flake-helper.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/lib/flake-helper.nix')
-rw-r--r--nix/lib/flake-helper.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/nix/lib/flake-helper.nix b/nix/lib/flake-helper.nix
index 6bd1c11..99522c0 100644
--- a/nix/lib/flake-helper.nix
+++ b/nix/lib/flake-helper.nix
@@ -141,6 +141,15 @@ rec {
 					then deploy-rs.lib.aarch64-darwin.activate.darwin
 						self.darwinConfigurations."${name}"
 					else "");
+
+		  # Timeout for profile activation.
+		  # This defaults to 240 seconds.
+		  activationTimeout = 600;
+
+		  # Timeout for profile activation confirmation.
+		  # This defaults to 30 seconds.
+		  confirmTimeout = 120;
+
 		};
 	};