about summary refs log tree commit diff
path: root/nix/lib/flake-helper.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/lib/flake-helper.nix')
-rw-r--r--nix/lib/flake-helper.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/nix/lib/flake-helper.nix b/nix/lib/flake-helper.nix
index 37e7b1f..b720232 100644
--- a/nix/lib/flake-helper.nix
+++ b/nix/lib/flake-helper.nix
@@ -36,7 +36,10 @@ rec {
 
 		modules = modules ++ [
 
-      self.nixosModules.emile
+			(if system == "x86_64-linux" then self.nixosModules.x86_64-linux
+				else
+					if system == "aarch64-darwin" then ({})
+					else null)
 
 			# a module so that we can access the flake output from inside the
 			# flake (yes, I need this for fetching the system type while building the hosts for deploy-rs)
@@ -46,6 +49,7 @@ rec {
 			({ ... }: {
 				nixpkgs.overlays = [
 					self.overlays.emile
+					
 					(_: _: { inherit (agenix.packages."x86_64-linux") agenix; })
 					(_: _: {
 						unstable = import nixpkgs-unstable {