about summary refs log tree commit diff
path: root/nix/pkgs/remarvin/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/pkgs/remarvin/default.nix')
-rw-r--r--nix/pkgs/remarvin/default.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/nix/pkgs/remarvin/default.nix b/nix/pkgs/remarvin/default.nix
new file mode 100644
index 0000000..1da157f
--- /dev/null
+++ b/nix/pkgs/remarvin/default.nix
@@ -0,0 +1,35 @@
+{
+  pkgs,
+  lib,
+  fetchgit,
+}:
+
+pkgs.buildGoModule rec {
+  name = "remarvin-${version}";
+  version = "0.1.1";
+
+  src = fetchgit {
+    url = "git://git.emile.space/remarvin.git";
+    hash = "sha256-UahNwhsxFGSpaVTk2EFtjt/MCB4Ec/08QStylL2QPUM=";
+  };
+
+  vendorHash = null;
+  CGO_ENABLED = 0;
+  subPackages = [ "src" ];
+
+  postInstall = ''
+    mkdir -p $out
+    cp -r templates $out
+
+    mv $out/bin/src $out/bin/remarvin
+  '';
+
+  doCheck = false;
+
+  meta = {
+    description = "A small marvin bot";
+    homepage = src.url;
+    license = lib.licenses.mit;
+    maintainers = with lib.maintainers; [ hanemile ];
+  };
+}