about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorEmile <git@emile.space>2023-10-31 20:03:19 +0100
committerEmile <git@emile.space>2023-10-31 20:03:19 +0100
commit392a7db129387fb2ca8846f7486cfb1b08e721d7 (patch)
tree31440941474e2c4152eef378df00f11926cbd9d7 /flake.nix
initial commit
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix80
1 files changed, 80 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..56f65b9
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,80 @@
+{
+  inputs = {
+    nixpkgs.url = "github:nixos/nixpkgs/release-23.05";
+  };
+
+  outputs = { nixpkgs, ... }: let
+    pkgs = import nixpkgs {
+      system = "aarch64-darwin";
+    };
+
+    packageVersions = {
+      # Wyze Cam Outdoor v1 Firmware
+      # https://support.wyze.com/hc/en-us/articles/360024852172-Release-Notes-Firmware
+
+      # v1 normal
+      "wyze-4_17_4_418" = rec {
+        name = "Wyze Cam Outdoor v1 Firmware ${version}";
+        basePath = "wcov";
+        version = "wco_cam_4.17.4.418";
+        hash = "sha256-bbHawgxUYfLotayyomQMFMsMjXT+2azab6Ey6yGe+No=";
+       };
+      "wyze-4_17_4_394" = rec {
+        name = "Wyze Cam Outdoor v1 Firmware ${version}";
+        basePath = "wcov";
+        version = "wco_cam_4.17.4.394";
+        hash = "sha256-x0hnWHhkFu8jIPcQjJaIIIiz6lLsC1A+2uDErhNLmKQ=";
+       };
+
+      # v1 sd
+      "wyze-4_17_4_124" = rec {
+        name = "Wyze Cam Outdoor v1 Firmware ${version}";
+        basePath = "wcov";
+        version = "wco_cam_sd_4.17.4.124";
+        hash = "sha256-GJRUEB7NBnaoWXhGpi7ZF50V1U3w5lQuIMUWV0WMXA0=";
+       };
+      "wyze-4_17_3_93" = rec {
+        name = "Wyze Cam Outdoor v1 Firmware ${version}";
+        basePath = "wcov";
+        version = "wco_cam_sd_4.17.3.93";
+        hash = "sha256-9iS8rR9ncKQUMcf17lwHFYBD3GbDhLYvZEUopcZfoPY=";
+       };
+
+      # v2
+      "wyze-4_48_4_418" = rec {
+        name = "Wyze Cam Outdoor v2 Firmware ${version}";
+        basePath = "wcov2";
+        version = "wco_cam_4.48.4.418";
+        hash = "sha256-1KAo8E77XI+4PcrjdDRtNDTB/g24I6rffprshuQgcbs=";
+      };
+      "wyze-4_48_4_394" = rec {
+        name = "Wyze Cam Outdoor v2 Firmware ${version}";
+        basePath = "wcov2";
+        version = "wco_cam_4.48.4.394";
+        hash = "sha256-yVsQ9EIxazsOLn9NuCOn7RMC7ACdbTlEi7CueReNJm4=";
+      };
+      "wyze-4_48_4_124" = rec {
+        name = "Wyze Cam Outdoor v2 Firmware ${version}";
+        basePath = "wcov2";
+        version = "wco_cam_v2_sd_4.48.4.124";
+        hash = "sha256-RqIpNR5DVDloTtjf0K+93VNfv74o2p01c0ekh8YZtJw=";
+      };
+
+      # Wyze Cam Outdoor Base Station Firmware
+      "wyze-4_16_4_496" = rec {
+        name = "Wyze Cam Outdoor Base Station Firmware ${version}";
+        basePath = "base";
+        version = "wco_station_sd_4.16.4.496";
+        hash = "sha256-pw0KLYrQlaKm/AnS0Qr18IQIDCgQcQnhwMfQ7C+Junk=";
+      };
+    };
+  in {
+    packages."aarch64-darwin" = nixpkgs.lib.mapAttrs
+      (name: attrs:
+        import ./wyze.nix {
+          inherit pkgs;
+          inherit attrs;
+        }
+      ) packageVersions;
+  };
+}