about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorEmile <git@emile.space>2025-02-13 22:29:30 +0100
committerEmile <git@emile.space>2025-02-13 22:29:30 +0100
commit176a24b152d1c20c841ceacb7b75694bbe521400 (patch)
tree9cc8442c825d3f2556ce664f2cc722aab025f2e7 /flake.nix
parenta9fd99521e3f74547b078a73e821f8c718ba40ec (diff)
flake: hydraJobs.templates: just got rid of the self.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 1 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index 899500a..51e0093 100644
--- a/flake.nix
+++ b/flake.nix
@@ -225,13 +225,11 @@
                 (
                   (import ./nix/templates/${name}/flake.nix).outputs) {
                     inherit nixpkgs flake-utils;
-                    # Self needs to be the imported flake, as some packages in some templates rely on each other, such as the goapp/backend-docker package which relies on the goapp/backend-pkg. Cross-template references are not supported (yet);
-                    self = import ./nix/templates/${name}/flake.nix;
                   }).packages or {})
               templ);
       in {
         inherit (self) packages;
-        # nixosConfigurations = helper.buildHosts self.nixosConfigurations;
+        nixosConfigurations = helper.buildHosts self.nixosConfigurations;
         templates = template-packages self.templates;
       };