about summary refs log tree commit diff
path: root/nix/hosts/caladan/home_emile.nix
diff options
context:
space:
mode:
authorEmile <git@emile.space>2025-04-11 19:34:46 +0200
committerEmile <git@emile.space>2025-04-11 19:34:46 +0200
commitdacdb0271517dee262aef2b8526330057311dd1d (patch)
treeffaaa18f8a52005029618941df2e25787d978c96 /nix/hosts/caladan/home_emile.nix
parent2d752da3b9225d5906aa18f589511fead268c1ce (diff)
(caladan) home stuff
Diffstat (limited to 'nix/hosts/caladan/home_emile.nix')
-rw-r--r--nix/hosts/caladan/home_emile.nix21
1 files changed, 19 insertions, 2 deletions
diff --git a/nix/hosts/caladan/home_emile.nix b/nix/hosts/caladan/home_emile.nix
index 86d6965..545c4d5 100644
--- a/nix/hosts/caladan/home_emile.nix
+++ b/nix/hosts/caladan/home_emile.nix
@@ -1,4 +1,4 @@
-{ pkgs, ... }:
+{ lib, pkgs, ... }:
 
 {
   home = {
@@ -60,6 +60,18 @@
       '';
     };
 
+    neovim = let
+      custom_plugins = pkgs.callPackage ./nvim_plugins.nix { };
+    in {
+      enable = true;
+      plugins = with pkgs.vimPlugins // custom_plugins; [
+        neovim-ayu
+        lisp.vlime
+      ];
+      extraConfig = ''
+      '';
+    };
+
     emacs = {
       enable = true;
       package = pkgs.emacs;
@@ -174,7 +186,7 @@
     nixos-rebuild
 
     # editor
-    unstable.helix
+    unstable-darwin.helix
 
     ## formatter
     nixfmt-rfc-style # official formatter for nix code
@@ -200,6 +212,7 @@
     # go foo
     go
     delve
+    gotools
 
     # c foo
     cmake
@@ -249,6 +262,10 @@
 
     drawio
 
+    # cargo rustup
+    cargo
+
+    # custom
     libc-database
 
     # blender