about summary refs log tree commit diff
path: root/nix/hosts/caladan/home_emile.nix
diff options
context:
space:
mode:
authorEmile <git@emile.space>2024-09-19 10:48:16 +0200
committerEmile <git@emile.space>2024-09-19 10:48:16 +0200
commite833c13c177288b2a7b9168a784e0e6562c025b6 (patch)
tree1661dad1694989e2d83e6c2fca7b5602a61c574b /nix/hosts/caladan/home_emile.nix
parentdcde3882d5460368e3c0499a54330f84a6995d62 (diff)
big format using nixfmt
Diffstat (limited to 'nix/hosts/caladan/home_emile.nix')
-rw-r--r--nix/hosts/caladan/home_emile.nix53
1 files changed, 37 insertions, 16 deletions
diff --git a/nix/hosts/caladan/home_emile.nix b/nix/hosts/caladan/home_emile.nix
index ee6c64b..c700da6 100644
--- a/nix/hosts/caladan/home_emile.nix
+++ b/nix/hosts/caladan/home_emile.nix
@@ -14,7 +14,7 @@
     # let home-manager install and manage itself
     home-manager.enable = true;
 
-    direnv = { 
+    direnv = {
       enable = true;
       nix-direnv.enable = true;
     };
@@ -33,7 +33,11 @@
       # enableAutosuggestions = true;
       oh-my-zsh = {
         enable = true;
-        plugins = [ "git" "web-search" "urltools" ];
+        plugins = [
+          "git"
+          "web-search"
+          "urltools"
+        ];
       };
 
       defaultKeymap = "viins";
@@ -59,11 +63,12 @@
     emacs = {
       enable = true;
       package = pkgs.emacs;
-      extraPackages = epkgs: with epkgs; [
-        nix-mode
-        magit
-        meow
-      ];
+      extraPackages =
+        epkgs: with epkgs; [
+          nix-mode
+          magit
+          meow
+        ];
       extraConfig = ''
         (setq standard-indent 2)
 
@@ -407,16 +412,30 @@
   };
 
   home.packages = with pkgs; [
-    coreutils mpv
+    coreutils
+    mpv
 
     # terminal foo
     # kitty
-    jq ripgrep fd eza lsd tree broot
-    du-dust mktemp htop rsync
-    p7zip imagemagick binwalk lftp
+    jq
+    ripgrep
+    fd
+    eza
+    lsd
+    tree
+    broot
+    du-dust
+    mktemp
+    htop
+    rsync
+    p7zip
+    imagemagick
+    binwalk
+    lftp
     graphviz
 
-    git tig 
+    git
+    tig
 
     # nix related tools
     deploy-rs
@@ -442,7 +461,8 @@
     yarr
 
     # go foo
-    go delve
+    go
+    delve
 
     # c foo
     cmake
@@ -458,7 +478,7 @@
 
     # qemu tooling
     qemu
-    sphinx #docs
+    sphinx # docs
     virt-manager
 
     # lisp foo
@@ -468,7 +488,8 @@
     clisp
 
     # infrastructure as code foo
-    terraform ansible
+    terraform
+    ansible
 
     portmidi
 
@@ -480,6 +501,6 @@
 
     # blender
 
-  # ] ++ lib.optionals stdenv.isDarwin [
+    # ] ++ lib.optionals stdenv.isDarwin [
   ];
 }