about summary refs log tree commit diff
path: root/nix/hosts/caladan/nvim_plugins.nix
diff options
context:
space:
mode:
authorEmile <git@emile.space>2025-04-11 19:34:46 +0200
committerEmile <git@emile.space>2025-04-11 19:34:46 +0200
commitdacdb0271517dee262aef2b8526330057311dd1d (patch)
treeffaaa18f8a52005029618941df2e25787d978c96 /nix/hosts/caladan/nvim_plugins.nix
parent2d752da3b9225d5906aa18f589511fead268c1ce (diff)
(caladan) home stuff
Diffstat (limited to 'nix/hosts/caladan/nvim_plugins.nix')
-rw-r--r--nix/hosts/caladan/nvim_plugins.nix9
1 files changed, 3 insertions, 6 deletions
diff --git a/nix/hosts/caladan/nvim_plugins.nix b/nix/hosts/caladan/nvim_plugins.nix
index 2bc46d7..7f07816 100644
--- a/nix/hosts/caladan/nvim_plugins.nix
+++ b/nix/hosts/caladan/nvim_plugins.nix
@@ -1,14 +1,11 @@
 { vimUtils, fetchgit, ... }:
 
 let
-  build-vim = vimUtils.buildVimPluginFrom2Nix;
-
-  build = ({name, owner, rev, sha256}: build-vim {
-    name = name;
+  build = ({name, owner, rev, sha256}: vimUtils.buildVimPlugin {
+    inherit name;
     src = fetchgit {
+      inherit rev sha256;
       url = "https://github.com/${owner}/${name}";
-      rev = rev;
-      sha256 = sha256;
     };
     dependencies = [];
   });