about summary refs log tree commit diff
path: root/nix/hosts/corrino/configuration.nix
diff options
context:
space:
mode:
authorEmile <git@emile.space>2024-05-30 10:24:53 +0200
committerEmile <git@emile.space>2024-05-30 10:24:53 +0200
commit6228cdcb65fb63fca1cf207bcf53233e5ae6bba7 (patch)
tree5ce2e12f30d8f6e271926c6c19b52a33bfb829a4 /nix/hosts/corrino/configuration.nix
parentb39d53e1f377654e4ac4197e4f717b225a7ebc45 (diff)
started centralizing the ssh keys
Diffstat (limited to 'nix/hosts/corrino/configuration.nix')
-rw-r--r--nix/hosts/corrino/configuration.nix23
1 files changed, 13 insertions, 10 deletions
diff --git a/nix/hosts/corrino/configuration.nix b/nix/hosts/corrino/configuration.nix
index fac958e..342916d 100644
--- a/nix/hosts/corrino/configuration.nix
+++ b/nix/hosts/corrino/configuration.nix
@@ -2,6 +2,12 @@
 
 let
   ports = import ./ports.nix;
+  keys = {
+    emile = [
+        "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIPZi43zHEsoWaQomLGaftPE5k0RqVrZyiTtGqZlpWsew emile@caladan"
+        "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIMoHWyC9r0LVk6UlkhBWAJph0F6KHYHh83EI5U9wtfq2 shortcuts@ginaz"
+    ];
+  };
 in {
   imports =
     [ # Include the results of the hardware scan.
@@ -269,9 +275,7 @@ in {
   users.users = {
     root = {
       initialHashedPassword = "";
-      openssh.authorizedKeys.keys = [
-        "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIPZi43zHEsoWaQomLGaftPE5k0RqVrZyiTtGqZlpWsew emile@caladan"
-      ];
+      openssh.authorizedKeys.keys = [] ++ keys.emile;
       packages = with pkgs; [
         mdadm
         tailscale
@@ -287,18 +291,17 @@ in {
 
     hack = {
       isNormalUser = true;
-      openssh.authorizedKeys.keys = [
-        "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIPZi43zHEsoWaQomLGaftPE5k0RqVrZyiTtGqZlpWsew emile@caladan"
-      ];
+      openssh.authorizedKeys.keys = [] ++ keys.emile;
       extraGroups = [ "docker" "libvirtd" ];
     };
 
     tmpuser1 = {
       isNormalUser = true;
-      openssh.authorizedKeys.keys = [
-        "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIPZi43zHEsoWaQomLGaftPE5k0RqVrZyiTtGqZlpWsew emile@caladan"
-        # "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIJMMq7gVuOuJEuarcsss2pb4JJS39zW/Fuow0foyqlV5 noobtracker@noobtracker-linux"
-      ];
+
+      # TODO(emile): readd after the whole user system is setup
+      # "ssh-ed25519 AAAAC3NzaC1lZDI1NTE5AAAAIJMMq7gVuOuJEuarcsss2pb4JJS39zW/Fuow0foyqlV5 noobtracker@noobtracker-linux"
+
+      openssh.authorizedKeys.keys = [] ++ keys.emile;
     };
   };