about summary refs log tree commit diff
path: root/nix/hosts/corrino/configuration.nix
diff options
context:
space:
mode:
authorEmile <git@emile.space>2024-03-26 10:30:12 +0100
committerEmile <git@emile.space>2024-03-26 10:32:37 +0100
commitcb20d078360ec9235b9b3a78d7950ded1f601267 (patch)
tree52d5ab591c843d9a7e888369f8315410c86e2203 /nix/hosts/corrino/configuration.nix
parentdfed6d17ebc3494fc783b7a345b342d59e4e325a (diff)
ports.nix file containing the used ports in a central location
Done and deployed in the 15min train ride to the office, quick and easy!
Diffstat (limited to 'nix/hosts/corrino/configuration.nix')
-rw-r--r--nix/hosts/corrino/configuration.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/nix/hosts/corrino/configuration.nix b/nix/hosts/corrino/configuration.nix
index c97d09f..dbc952c 100644
--- a/nix/hosts/corrino/configuration.nix
+++ b/nix/hosts/corrino/configuration.nix
@@ -1,5 +1,8 @@
 { config, pkgs, ... }:
-{
+
+let
+  ports = import ./ports.nix;
+in {
   imports =
     [ # Include the results of the hardware scan.
       ./hardware-configuration.nix
@@ -57,7 +60,7 @@
           enable = true;
       
           # ssh port during boot for luks decryption
-          port = 2222;
+          port = ports.initrd_ssh;
           authorizedKeys = config.users.users.root.openssh.authorizedKeys.keys;
           hostKeys = [ "/initrd_ssh_host_ecdsa_key" ];
         };