about summary refs log tree commit diff
path: root/nix/hosts/corrino/www/ctf.emile.space.nix
diff options
context:
space:
mode:
authorEmile <git@emile.space>2024-03-09 22:56:01 +0100
committerEmile <git@emile.space>2024-03-09 22:56:01 +0100
commit55ee036fd7ebed24097c8da1ca8a0b0829264670 (patch)
tree9c600d75a4f59f8ec253c5caadc1f77b2cecb0da /nix/hosts/corrino/www/ctf.emile.space.nix
big bang
Diffstat (limited to 'nix/hosts/corrino/www/ctf.emile.space.nix')
-rw-r--r--nix/hosts/corrino/www/ctf.emile.space.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/nix/hosts/corrino/www/ctf.emile.space.nix b/nix/hosts/corrino/www/ctf.emile.space.nix
new file mode 100644
index 0000000..c4de8c5
--- /dev/null
+++ b/nix/hosts/corrino/www/ctf.emile.space.nix
@@ -0,0 +1,26 @@
+{ ... }:
+
+{
+  services.nginx.virtualHosts."ctf.emile.space" = {
+    forceSSL = true;
+    enableACME = true;
+
+    locations = {
+      "/" = {
+        proxyPass = "http://127.0.0.1:8338";
+      };
+    };
+  };
+
+  virtualisation.oci-containers = {
+    backend = "docker";
+    containers = {
+      "ctfd" = {
+        image = "ctfd/ctfd";
+        ports = [
+          "8338:8000"
+        ];
+      };
+    };
+  };
+}