about summary refs log tree commit diff
path: root/nix/hosts/corrino/www/ctf.emile.space.nix
diff options
context:
space:
mode:
authorEmile <git@emile.space>2024-03-26 10:30:12 +0100
committerEmile <git@emile.space>2024-03-26 10:32:37 +0100
commitcb20d078360ec9235b9b3a78d7950ded1f601267 (patch)
tree52d5ab591c843d9a7e888369f8315410c86e2203 /nix/hosts/corrino/www/ctf.emile.space.nix
parentdfed6d17ebc3494fc783b7a345b342d59e4e325a (diff)
ports.nix file containing the used ports in a central location
Done and deployed in the 15min train ride to the office, quick and easy!
Diffstat (limited to 'nix/hosts/corrino/www/ctf.emile.space.nix')
-rw-r--r--nix/hosts/corrino/www/ctf.emile.space.nix8
1 files changed, 5 insertions, 3 deletions
diff --git a/nix/hosts/corrino/www/ctf.emile.space.nix b/nix/hosts/corrino/www/ctf.emile.space.nix
index c4de8c5..5c9d49a 100644
--- a/nix/hosts/corrino/www/ctf.emile.space.nix
+++ b/nix/hosts/corrino/www/ctf.emile.space.nix
@@ -1,13 +1,15 @@
 { ... }:
 
-{
+let
+  ports = import ../ports.nix;
+in {
   services.nginx.virtualHosts."ctf.emile.space" = {
     forceSSL = true;
     enableACME = true;
 
     locations = {
       "/" = {
-        proxyPass = "http://127.0.0.1:8338";
+        proxyPass = "http://127.0.0.1:${toString ports.ctf}";
       };
     };
   };
@@ -18,7 +20,7 @@
       "ctfd" = {
         image = "ctfd/ctfd";
         ports = [
-          "8338:8000"
+          "${toString ports.ctf}:8000"
         ];
       };
     };