about summary refs log tree commit diff
path: root/nix/hosts/corrino/www/git.emile.space.nix
diff options
context:
space:
mode:
authorEmile <git@emile.space>2024-03-26 10:30:12 +0100
committerEmile <git@emile.space>2024-03-26 10:32:37 +0100
commitcb20d078360ec9235b9b3a78d7950ded1f601267 (patch)
tree52d5ab591c843d9a7e888369f8315410c86e2203 /nix/hosts/corrino/www/git.emile.space.nix
parentdfed6d17ebc3494fc783b7a345b342d59e4e325a (diff)
ports.nix file containing the used ports in a central location
Done and deployed in the 15min train ride to the office, quick and easy!
Diffstat (limited to 'nix/hosts/corrino/www/git.emile.space.nix')
-rw-r--r--nix/hosts/corrino/www/git.emile.space.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/nix/hosts/corrino/www/git.emile.space.nix b/nix/hosts/corrino/www/git.emile.space.nix
index dceadb6..f05c83d 100644
--- a/nix/hosts/corrino/www/git.emile.space.nix
+++ b/nix/hosts/corrino/www/git.emile.space.nix
@@ -2,6 +2,7 @@
 
 let
   cfg = config.services.gitea;
+  ports = import ../ports.nix;
   authelia-location = ''
     set $upstream_authelia http://127.0.0.1:9091/api/authz/auth-request;
 
@@ -81,7 +82,8 @@ in {
 
     locations = {
       "/" = {
-        proxyPass = "http://127.0.0.1:3000";
+        # proxyPass = "http://127.0.0.1:3000";
+        proxyPass = "http://127.0.0.1:${toString config.services.gitea.settings.server.HTTP_PORT}";
 
         # TODO(emile): figure out why this doesn't work when enabled, has to do with authelia
         # extraConfig = authelia-authrequest;
@@ -131,6 +133,7 @@ in {
       server = {
         DOMAIN = pkgs.lib.mkForce "git.emile.space";
         ROOT_URL = pkgs.lib.mkForce "https://git.emile.space";
+        HTTP_PORT = ports.git;
 
         #START_SSH_SERVER = true;
         BUILTIN_SSH_SERVER_USER = "git";