about summary refs log tree commit diff
path: root/nix/hosts/corrino/www/znc.emile.space.nix
diff options
context:
space:
mode:
authorEmile <git@emile.space>2024-03-09 22:56:01 +0100
committerEmile <git@emile.space>2024-03-09 22:56:01 +0100
commit55ee036fd7ebed24097c8da1ca8a0b0829264670 (patch)
tree9c600d75a4f59f8ec253c5caadc1f77b2cecb0da /nix/hosts/corrino/www/znc.emile.space.nix
big bang
Diffstat (limited to 'nix/hosts/corrino/www/znc.emile.space.nix')
-rw-r--r--nix/hosts/corrino/www/znc.emile.space.nix47
1 files changed, 47 insertions, 0 deletions
diff --git a/nix/hosts/corrino/www/znc.emile.space.nix b/nix/hosts/corrino/www/znc.emile.space.nix
new file mode 100644
index 0000000..7a790ed
--- /dev/null
+++ b/nix/hosts/corrino/www/znc.emile.space.nix
@@ -0,0 +1,47 @@
+{ ... }:
+
+{
+  services.nginx.virtualHosts."znc.emile.space" = {
+    forceSSL = true;
+    enableACME = true;
+
+    locations = {
+      "/" = {
+        proxyPass = "http://127.0.0.1:5000";
+      };
+    };
+  };
+
+  services.znc = {
+    enable = true;
+    openFirewall = true;
+    useLegacyConfig = false;
+
+    config = {
+      LoadModule = [ ];
+      User.Emile = {
+        Admin = true;
+        Nick = "hanemile";
+        RealName = "Emile";
+        # QuitMsg = "iowait()";
+        LoadModule = [ "chansaver" "controlpanel" ];
+
+        Network.libera = {
+          Server = "irc.libera.chat +6697";
+          LoadModule = [ "simple_away" ];
+          Chan = {
+            "#nixos" = { Detached = false; };
+            "##linux" = { Disabled = true; };
+          };
+        };
+
+        Pass.password = { # hunter2
+          Method = "sha256";
+          Hash =
+            "31357a874d929871b7c2267721501aaa1f3c570ddc72eb6fb6d065fe72dbc2e4";
+          Salt = "Oo1du8jahquataexai6Eiph9OcohpoL3";
+        };
+      };
+    };
+  };
+}