about summary refs log tree commit diff
path: root/nix/lib/default.nix
diff options
context:
space:
mode:
authorEmile <git@emile.space>2024-03-09 22:56:01 +0100
committerEmile <git@emile.space>2024-03-09 22:56:01 +0100
commit55ee036fd7ebed24097c8da1ca8a0b0829264670 (patch)
tree9c600d75a4f59f8ec253c5caadc1f77b2cecb0da /nix/lib/default.nix
big bang
Diffstat (limited to 'nix/lib/default.nix')
-rw-r--r--nix/lib/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/nix/lib/default.nix b/nix/lib/default.nix
new file mode 100644
index 0000000..99a47fc
--- /dev/null
+++ b/nix/lib/default.nix
@@ -0,0 +1,22 @@
+# original:
+# https://git.clerie.de/clerie/nixfiles/src/branch/master/lib/default.nix
+
+inputs:
+
+let
+	callLibs = file: import file ({
+		inherit lib inputs;
+	} // inputs);
+
+	lib = {
+		flake-helper = callLibs ./flake-helper.nix;
+		inherit ("flake-helper")
+			generateSystem
+			mapToNixosConfigurations
+			mapToDarwinConfigurations
+			generateDeployRsHost
+			mapToDeployRsConfiguration
+			buildHosts;
+	};
+in
+	lib