about summary refs log tree commit diff
path: root/nix/lib/default.nix
diff options
context:
space:
mode:
authorEmile <git@emile.space>2024-09-19 10:48:16 +0200
committerEmile <git@emile.space>2024-09-19 10:48:16 +0200
commite833c13c177288b2a7b9168a784e0e6562c025b6 (patch)
tree1661dad1694989e2d83e6c2fca7b5602a61c574b /nix/lib/default.nix
parentdcde3882d5460368e3c0499a54330f84a6995d62 (diff)
big format using nixfmt
Diffstat (limited to 'nix/lib/default.nix')
-rw-r--r--nix/lib/default.nix27
1 files changed, 13 insertions, 14 deletions
diff --git a/nix/lib/default.nix b/nix/lib/default.nix
index 99a47fc..1fc134e 100644
--- a/nix/lib/default.nix
+++ b/nix/lib/default.nix
@@ -4,19 +4,18 @@
 inputs:
 
 let
-	callLibs = file: import file ({
-		inherit lib inputs;
-	} // inputs);
+  callLibs = file: import file ({ inherit lib inputs; } // inputs);
 
-	lib = {
-		flake-helper = callLibs ./flake-helper.nix;
-		inherit ("flake-helper")
-			generateSystem
-			mapToNixosConfigurations
-			mapToDarwinConfigurations
-			generateDeployRsHost
-			mapToDeployRsConfiguration
-			buildHosts;
-	};
+  lib = {
+    flake-helper = callLibs ./flake-helper.nix;
+    inherit ("flake-helper")
+      generateSystem
+      mapToNixosConfigurations
+      mapToDarwinConfigurations
+      generateDeployRsHost
+      mapToDeployRsConfiguration
+      buildHosts
+      ;
+  };
 in
-	lib
+lib