about summary refs log tree commit diff
path: root/nix/lib/flake-helper.nix
diff options
context:
space:
mode:
authorEmile <git@emile.space>2025-01-28 00:39:14 +0100
committerEmile <git@emile.space>2025-01-28 00:39:14 +0100
commit35434dbac0e5cd779e3cb8b5f892b3647005f0c0 (patch)
treed05d0a53277f944c62a6e18f1aed2e433e2c7bf8 /nix/lib/flake-helper.nix
parent3874e7f759fb73529cb21a41209410b0f08b37c9 (diff)
flake-helpers: formatting and ssh opts
Diffstat (limited to 'nix/lib/flake-helper.nix')
-rw-r--r--nix/lib/flake-helper.nix8
1 files changed, 3 insertions, 5 deletions
diff --git a/nix/lib/flake-helper.nix b/nix/lib/flake-helper.nix
index 2f8a020..ddace97 100644
--- a/nix/lib/flake-helper.nix
+++ b/nix/lib/flake-helper.nix
@@ -51,9 +51,7 @@ rec {
       # allow the usage of the inputs within the systemd
       # for example:
       # { pkgs, ... } @ args: { imports = ["${args.inputs.nixpkgs-unstable}/path/to/module.nix"] }
-      specialArgs = {
-        inherit inputs;
-      };
+      specialArgs = { inherit inputs self; };
 
       # ; nix repl
       # nix-repl> :lf .
@@ -200,8 +198,8 @@ rec {
         sshUser = sshUser; # user to ssh to as
 
         # make sure people can use sudo 
-        # sshOpts = ["-A", "-t", "-S"];
-        sshOpts = [ "-o"  "ProxyCommand=none" ];
+        sshOpts = ["-A" "-t" "-S"];
+        # sshOpts = [ "-o"  "ProxyCommand=none" ];
 
         # make sure to add the nix foo on the darwin hosts to ~/.zshenv
         # as the ~/.zshrc doesn't get sourced when ssh-ing into the system