about summary refs log tree commit diff
path: root/nix/pkgs/libc-database/default.nix
diff options
context:
space:
mode:
authorEmile <git@emile.space>2025-02-10 19:34:33 +0100
committerEmile <git@emile.space>2025-02-10 19:34:33 +0100
commit89af5d64e2bc74f4c9a41926f0366ed9e2f9a35b (patch)
tree1979027002fac743916999fef0ea56f4dab5e7dd /nix/pkgs/libc-database/default.nix
parentc4d4ae7ad1c95051e8b9770eebd883fa3dd1e5f3 (diff)
chaos: a bit collection of random changes
Diffstat (limited to 'nix/pkgs/libc-database/default.nix')
-rw-r--r--nix/pkgs/libc-database/default.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/nix/pkgs/libc-database/default.nix b/nix/pkgs/libc-database/default.nix
new file mode 100644
index 0000000..4ddcf07
--- /dev/null
+++ b/nix/pkgs/libc-database/default.nix
@@ -0,0 +1,34 @@
+{
+  pkgs ? import <nixpkgs> { },
+  lib,
+  fetchFromGitHub,
+  ...
+}:
+
+pkgs.stdenv.mkDerivation rec {
+  name = "libc-database-${version}";
+  version = "master";
+
+  src = fetchFromGitHub {
+    owner = "niklasb";
+    repo = "libc-database";
+    rev = version;
+    sha256 = "Zysjhr76TenMarnoKo+M8DrTNbsnaXSoFZO1puPVoxU=";
+  };
+
+  # not building, we just want to download the repo
+  buildPhase = '''';
+
+  installPhase = ''
+		mkdir -p $out/bin
+		ls -l
+		cp add download dump find get identify $out/bin/
+  '';
+
+  meta = {
+    description = "Build a database of libc offsets to simplify exploitation";
+    homepage = "https://github.com/niklasb/libc-database";
+    license = lib.license.mit;
+    maintainers = with lib.maintainers; [ hanemile ];
+  };
+}