about summary refs log tree commit diff
path: root/nix/pkgs/r2wars-web
diff options
context:
space:
mode:
authorEmile <git@emile.space>2025-01-28 12:46:24 +0100
committerEmile <git@emile.space>2025-01-28 12:46:24 +0100
commit48208a695bdb6cc1adf3374ae5ed507291726185 (patch)
tree6cbb28d3dcdc10c7c50cb09b33acd5e68e28cae7 /nix/pkgs/r2wars-web
parent3be875a995bc9cd5e198b705764ed5caa51d7b3c (diff)
r2wars-web pkg: fetching from github and actually installing
Diffstat (limited to 'nix/pkgs/r2wars-web')
-rw-r--r--nix/pkgs/r2wars-web/default.nix21
1 files changed, 12 insertions, 9 deletions
diff --git a/nix/pkgs/r2wars-web/default.nix b/nix/pkgs/r2wars-web/default.nix
index 0652547..1d55de3 100644
--- a/nix/pkgs/r2wars-web/default.nix
+++ b/nix/pkgs/r2wars-web/default.nix
@@ -1,16 +1,19 @@
 {
   pkgs,
   lib,
-  fetchgit,
+  fetchFromGitHub,
+  ...
 }:
 
 pkgs.buildGoModule rec {
   name = "r2wars-web-${version}";
   version = "0.1.2";
 
-  src = fetchgit {
-    url = "git://github.com/hanemile/r2wars-web.git";
-    hash = "sha256-/LOjnCnns7nIV25aKUFCNoE3sZrZ72lvWSBlD4zuHQc=";
+  src = fetchFromGitHub {
+    owner = "hanemile";
+    repo = "r2wars-web";
+    rev = "main";    
+    sha256 = "sha256-cKvdMPysrJonoBqxiXWyb8Nn6qr2Zn6eQqyGWRMgmao=";
   };
 
   vendorHash = null;
@@ -18,11 +21,11 @@ pkgs.buildGoModule rec {
   CGO_ENABLED = 0;
   subPackages = [ "src" ];
 
-  # postInstall = ''
-  #   mkdir -p $out
-  #   cp -r templates $out
-  #   mv $out/bin/src $out/bin/r2wars-web
-  # '';
+  postInstall = ''
+    mkdir -p $out
+    cp -r templates $out
+    mv $out/bin/src $out/bin/r2wars-web
+  '';
 
   doCheck = false;