about summary refs log tree commit diff
path: root/secrets.nix
diff options
context:
space:
mode:
authorEmile <git@emile.space>2024-03-25 15:33:18 +0100
committerEmile <git@emile.space>2024-03-25 15:33:18 +0100
commit7412d355acc2eae4a0b9857d94393a0e12e1b4ed (patch)
tree858a78396762a37499fa6fb8e5468b5f42ad6b5d /secrets.nix
parent27c9efa48891a7bb69ba0ef642e18cf5884a9e23 (diff)
description for the secret bootstraping problem
Diffstat (limited to 'secrets.nix')
-rw-r--r--secrets.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/secrets.nix b/secrets.nix
index 1a625d3..67bf9b9 100644
--- a/secrets.nix
+++ b/secrets.nix
@@ -5,6 +5,12 @@
 
 # nix eval --impure --expr 'import ./secrets.nix'
 
+# As we're generating the secret.nix, we have a bootstrapping problem:
+# agenix assumes that the to be generated secret is present in the
+# secret.nix file, but we've not created it yet.
+# Due to this, we've got a "new" file in the secrets directory that can be used
+# and renamed afterwards
+
 let
 	pubkeysFor = directory:
 		let