about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 1 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index 899500a..51e0093 100644
--- a/flake.nix
+++ b/flake.nix
@@ -225,13 +225,11 @@
                 (
                   (import ./nix/templates/${name}/flake.nix).outputs) {
                     inherit nixpkgs flake-utils;
-                    # Self needs to be the imported flake, as some packages in some templates rely on each other, such as the goapp/backend-docker package which relies on the goapp/backend-pkg. Cross-template references are not supported (yet);
-                    self = import ./nix/templates/${name}/flake.nix;
                   }).packages or {})
               templ);
       in {
         inherit (self) packages;
-        # nixosConfigurations = helper.buildHosts self.nixosConfigurations;
+        nixosConfigurations = helper.buildHosts self.nixosConfigurations;
         templates = template-packages self.templates;
       };