about summary refs log tree commit diff
path: root/nix/hosts/caladan/nvim_plugins.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/hosts/caladan/nvim_plugins.nix')
-rw-r--r--nix/hosts/caladan/nvim_plugins.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/nix/hosts/caladan/nvim_plugins.nix b/nix/hosts/caladan/nvim_plugins.nix
new file mode 100644
index 0000000..2bc46d7
--- /dev/null
+++ b/nix/hosts/caladan/nvim_plugins.nix
@@ -0,0 +1,24 @@
+{ vimUtils, fetchgit, ... }:
+
+let
+  build-vim = vimUtils.buildVimPluginFrom2Nix;
+
+  build = ({name, owner, rev, sha256}: build-vim {
+    name = name;
+    src = fetchgit {
+      url = "https://github.com/${owner}/${name}";
+      rev = rev;
+      sha256 = sha256;
+    };
+    dependencies = [];
+  });
+in {
+  lisp = {
+    vlime = build {
+      name = "vlime";
+      owner = "l04m33";
+      rev = "065b95f3ac7a455314c2bdefeb2b792f290034df";
+      sha256 = "1bmmskdwvbl6lvbnjp9lls86rz0vzmk73y644bjb9ix9ygmjbia4";
+    };
+  };
+}