about summary refs log tree commit diff
path: root/nix/hosts/caladan/nvim_plugins.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/hosts/caladan/nvim_plugins.nix')
-rw-r--r--nix/hosts/caladan/nvim_plugins.nix9
1 files changed, 3 insertions, 6 deletions
diff --git a/nix/hosts/caladan/nvim_plugins.nix b/nix/hosts/caladan/nvim_plugins.nix
index 2bc46d7..7f07816 100644
--- a/nix/hosts/caladan/nvim_plugins.nix
+++ b/nix/hosts/caladan/nvim_plugins.nix
@@ -1,14 +1,11 @@
 { vimUtils, fetchgit, ... }:
 
 let
-  build-vim = vimUtils.buildVimPluginFrom2Nix;
-
-  build = ({name, owner, rev, sha256}: build-vim {
-    name = name;
+  build = ({name, owner, rev, sha256}: vimUtils.buildVimPlugin {
+    inherit name;
     src = fetchgit {
+      inherit rev sha256;
       url = "https://github.com/${owner}/${name}";
-      rev = rev;
-      sha256 = sha256;
     };
     dependencies = [];
   });