about summary refs log tree commit diff
path: root/nix/hosts/chusuk/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/hosts/chusuk/hardware-configuration.nix')
-rw-r--r--nix/hosts/chusuk/hardware-configuration.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/nix/hosts/chusuk/hardware-configuration.nix b/nix/hosts/chusuk/hardware-configuration.nix
new file mode 100644
index 0000000..6b34e3b
--- /dev/null
+++ b/nix/hosts/chusuk/hardware-configuration.nix
@@ -0,0 +1,31 @@
+# Do not modify this file!  It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations.  Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+  imports =
+    [ (modulesPath + "/installer/scan/not-detected.nix")
+    ];
+
+  boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "nvme" "usb_storage" "sd_mod" ];
+  boot.initrd.kernelModules = [ ];
+  boot.kernelModules = [ "kvm-intel" ];
+  boot.extraModulePackages = [ ];
+
+  fileSystems."/" =
+    { device = "/dev/disk/by-uuid/22445c0e-71bd-488f-88e5-0abc60441e58";
+      fsType = "ext4";
+    };
+
+  fileSystems."/boot" =
+    { device = "/dev/disk/by-uuid/29BB-5D28";
+      fsType = "vfat";
+    };
+
+  swapDevices =
+    [ { device = "/dev/disk/by-uuid/d79efda2-1190-428c-8598-6911793175fb"; }
+    ];
+
+  powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+}