about summary refs log tree commit diff
path: root/nix/hosts/chusuk/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/hosts/chusuk/hardware-configuration.nix')
-rw-r--r--nix/hosts/chusuk/hardware-configuration.nix40
1 files changed, 24 insertions, 16 deletions
diff --git a/nix/hosts/chusuk/hardware-configuration.nix b/nix/hosts/chusuk/hardware-configuration.nix
index 6b34e3b..ebe26fc 100644
--- a/nix/hosts/chusuk/hardware-configuration.nix
+++ b/nix/hosts/chusuk/hardware-configuration.nix
@@ -1,31 +1,39 @@
 # Do not modify this file!  It was generated by ‘nixos-generate-config’
 # and may be overwritten by future invocations.  Please make changes
 # to /etc/nixos/configuration.nix instead.
-{ config, lib, pkgs, modulesPath, ... }:
+{
+  config,
+  lib,
+  pkgs,
+  modulesPath,
+  ...
+}:
 
 {
-  imports =
-    [ (modulesPath + "/installer/scan/not-detected.nix")
-    ];
+  imports = [ (modulesPath + "/installer/scan/not-detected.nix") ];
 
-  boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "nvme" "usb_storage" "sd_mod" ];
+  boot.initrd.availableKernelModules = [
+    "xhci_pci"
+    "ahci"
+    "nvme"
+    "usb_storage"
+    "sd_mod"
+  ];
   boot.initrd.kernelModules = [ ];
   boot.kernelModules = [ "kvm-intel" ];
   boot.extraModulePackages = [ ];
 
-  fileSystems."/" =
-    { device = "/dev/disk/by-uuid/22445c0e-71bd-488f-88e5-0abc60441e58";
-      fsType = "ext4";
-    };
+  fileSystems."/" = {
+    device = "/dev/disk/by-uuid/22445c0e-71bd-488f-88e5-0abc60441e58";
+    fsType = "ext4";
+  };
 
-  fileSystems."/boot" =
-    { device = "/dev/disk/by-uuid/29BB-5D28";
-      fsType = "vfat";
-    };
+  fileSystems."/boot" = {
+    device = "/dev/disk/by-uuid/29BB-5D28";
+    fsType = "vfat";
+  };
 
-  swapDevices =
-    [ { device = "/dev/disk/by-uuid/d79efda2-1190-428c-8598-6911793175fb"; }
-    ];
+  swapDevices = [ { device = "/dev/disk/by-uuid/d79efda2-1190-428c-8598-6911793175fb"; } ];
 
   powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
 }