about summary refs log tree commit diff
path: root/nix/hosts/corrino/remarvin.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/hosts/corrino/remarvin.nix')
-rw-r--r--nix/hosts/corrino/remarvin.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/nix/hosts/corrino/remarvin.nix b/nix/hosts/corrino/remarvin.nix
new file mode 100644
index 0000000..580cbbf
--- /dev/null
+++ b/nix/hosts/corrino/remarvin.nix
@@ -0,0 +1,17 @@
+{ config, ... }:
+
+{
+  # deploy:
+  # - push code
+  # - build in order to get the new hash (nix build .#remarvin)
+  # - update hash in the package (//nix/pkgs/remarvin/default.nix)
+  # - deploy
+
+  services.emile.remarvin = {
+    enable = true;
+
+    username = "marvin_test1";
+    homeserver = "matrix.org";
+    accesstoken = config.age.secrets.remarvin_accesstoken.path;
+  };
+}