about summary refs log tree commit diff
path: root/nix/hosts/corrino/www/loki.emile.space.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/hosts/corrino/www/loki.emile.space.nix')
-rw-r--r--nix/hosts/corrino/www/loki.emile.space.nix57
1 files changed, 57 insertions, 0 deletions
diff --git a/nix/hosts/corrino/www/loki.emile.space.nix b/nix/hosts/corrino/www/loki.emile.space.nix
new file mode 100644
index 0000000..1c1786f
--- /dev/null
+++ b/nix/hosts/corrino/www/loki.emile.space.nix
@@ -0,0 +1,57 @@
+{ config, ... }:
+
+{
+  services = {
+    loki = {
+      enable = false;
+      configuration = {
+        auth_enabled = false;
+        server = {
+          http_listen_port = config.emile.ports.loki;
+        };
+
+        limits_config = {
+          reject_old_samples = true;
+          reject_old_samples_max_age = "7d";
+          max_global_streams_per_user = 100000;
+          max_streams_per_user = 100000;
+        };
+
+        common = {
+          instance_addr = "127.0.0.1";
+          ring = {
+            instance_addr = "127.0.0.1";
+            kvstore.store = "inmemory";
+          };
+          replication_factor = 1;
+          path_prefix = "/tmp/loki";
+        };
+
+        # limits_config.allow_structured_metadata = false;
+
+        schema_config.configs = [
+          # {
+          #   from = "2023-05-09";
+          #   store = "boltdb-shipper";
+          #   object_store = "filesystem";
+          #   schema = "v13";
+          #   index = {
+          #     prefix = "index_";
+          #     period = "24h";
+          #   };
+          # }
+          {
+            from = "2024-10-18";
+            store = "tsdb";
+            object_store = "filesystem";
+            schema = "v13";
+            index = {
+              prefix = "index_";
+              period = "24h";
+            };
+          }
+        ];
+      };
+    };
+  };
+}