about summary refs log tree commit diff
path: root/nix/hosts/corrino/www/magic-hash.emile.space.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/hosts/corrino/www/magic-hash.emile.space.nix')
-rw-r--r--nix/hosts/corrino/www/magic-hash.emile.space.nix8
1 files changed, 3 insertions, 5 deletions
diff --git a/nix/hosts/corrino/www/magic-hash.emile.space.nix b/nix/hosts/corrino/www/magic-hash.emile.space.nix
index 4f57d12..f41fb80 100644
--- a/nix/hosts/corrino/www/magic-hash.emile.space.nix
+++ b/nix/hosts/corrino/www/magic-hash.emile.space.nix
@@ -1,15 +1,13 @@
 { config, ... }:
 
-let
-  ports = import ../ports.nix;
-in {
+{
   services.nginx.virtualHosts."magic-hash.emile.space" = {
     forceSSL = true;
     enableACME = true;
 
     locations = {
       "/" = {
-        proxyPass = "http://127.0.0.1:${toString ports.magic-hash}";
+        proxyPass = "http://127.0.0.1:${toString config.emile.ports.magic-hash}";
       };
     };
   };
@@ -20,7 +18,7 @@ in {
       "ctfd" = {
         image = "magic-hash";
         ports = [
-          "${toString ports.magic-hash}:80"
+          "${toString config.emile.ports.magic-hash}:80"
         ];
         environment = {