about summary refs log tree commit diff
path: root/nix/hosts/corrino/www/nix-cache/nix-cache.emile.space.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/hosts/corrino/www/nix-cache/nix-cache.emile.space.nix')
-rw-r--r--nix/hosts/corrino/www/nix-cache/nix-cache.emile.space.nix54
1 files changed, 27 insertions, 27 deletions
diff --git a/nix/hosts/corrino/www/nix-cache/nix-cache.emile.space.nix b/nix/hosts/corrino/www/nix-cache/nix-cache.emile.space.nix
index 690e422..c8f7264 100644
--- a/nix/hosts/corrino/www/nix-cache/nix-cache.emile.space.nix
+++ b/nix/hosts/corrino/www/nix-cache/nix-cache.emile.space.nix
@@ -1,10 +1,10 @@
 { ... }:
 
 {
-	services.nginx.virtualHosts."nix-cache.emile.space" = {
-		forceSSL = false;
-		enableACME = false;
-	};
+  services.nginx.virtualHosts."nix-cache.emile.space" = {
+    forceSSL = false;
+    enableACME = false;
+  };
   #   locations = {
   #     "/" = {
   #       root = "/var/www/emile.space";
@@ -12,10 +12,10 @@
   #         add_header Strict-Transport-Security "max-age=31536000; includeSubDomains" always;
   #       ''; 
   #     };
-		# };
-		# locations."= /" = {
-		# 	index = "/index.txt";
-		# };
+  # };
+  # locations."= /" = {
+  # 	index = "/index.txt";
+  # };
   #   locations."= /index.txt" = {
   #     root = ./index.txt;
   #   };
@@ -32,27 +32,27 @@
   #     '';
   #   };
   #   locations."/" = {
-		# 	proxyPass = "http://${config.services.harmonia.settings.bind}";
-		# 	extraConfig = ''
-	 #      proxy_set_header Host $host;
-	 #      proxy_redirect http:// https://;
-	 #      proxy_http_version 1.1;
-	 #      proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
-	 #      proxy_set_header Upgrade $http_upgrade;
-	 #      proxy_set_header Connection $connection_upgrade;
+  # 	proxyPass = "http://${config.services.harmonia.settings.bind}";
+  # 	extraConfig = ''
+  #      proxy_set_header Host $host;
+  #      proxy_redirect http:// https://;
+  #      proxy_http_version 1.1;
+  #      proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
+  #      proxy_set_header Upgrade $http_upgrade;
+  #      proxy_set_header Connection $connection_upgrade;
 
-	 #      zstd on;
-	 #      zstd_types application/x-nix-archive;
-		# 	'';
-		# };
-	# };
+  #      zstd on;
+  #      zstd_types application/x-nix-archive;
+  # 	'';
+  # };
+  # };
 
- #  services.harmonia = {
-	# 	enable = true;
+  #  services.harmonia = {
+  # 	enable = true;
 
-	# 	# TODO(emile): manage this using age
-	# 	signKeyPath = "/var/lib/secrets/harmonia.secret";
+  # 	# TODO(emile): manage this using age
+  # 	signKeyPath = "/var/lib/secrets/harmonia.secret";
 
- #    settings.bind = "[::1]:${toString config.emile.ports.harmonia}";
-	# };
+  #    settings.bind = "[::1]:${toString config.emile.ports.harmonia}";
+  # };
 }