about summary refs log tree commit diff
path: root/nix/hosts/corrino/www/pgweb.emile.space.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/hosts/corrino/www/pgweb.emile.space.nix')
-rw-r--r--nix/hosts/corrino/www/pgweb.emile.space.nix23
1 files changed, 0 insertions, 23 deletions
diff --git a/nix/hosts/corrino/www/pgweb.emile.space.nix b/nix/hosts/corrino/www/pgweb.emile.space.nix
deleted file mode 100644
index 1ce8063..0000000
--- a/nix/hosts/corrino/www/pgweb.emile.space.nix
+++ /dev/null
@@ -1,23 +0,0 @@
-{ pkgs, ... }:
-
-let
-  ports = import ../ports.nix;
-in {
-  services.nginx.virtualHosts."pgweb.emile.space" = {
-    forceSSL = true;
-    enableACME = true;
-
-    locations = {
-      "/" = {
-        proxyPass = "http://127.0.0.1:${toString ports.pgweb}";
-      };
-    };
-  };
-
-  environment.systemPackages = with pkgs; [ pgweb ];
-
-  # systemd.services.pgweb = {
-  #   wantedBy = [ "multi-user.target" ];
-  #   serviceConfig.ExecStart = "${pkgs.pgweb}/bin/pwgeb";
-  # };
-}