about summary refs log tree commit diff
path: root/nix/hosts/corrino/www/pgweb.emile.space.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/hosts/corrino/www/pgweb.emile.space.nix')
-rw-r--r--nix/hosts/corrino/www/pgweb.emile.space.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/nix/hosts/corrino/www/pgweb.emile.space.nix b/nix/hosts/corrino/www/pgweb.emile.space.nix
index 522a6bf..1ce8063 100644
--- a/nix/hosts/corrino/www/pgweb.emile.space.nix
+++ b/nix/hosts/corrino/www/pgweb.emile.space.nix
@@ -1,13 +1,15 @@
 { pkgs, ... }:
 
-{
+let
+  ports = import ../ports.nix;
+in {
   services.nginx.virtualHosts."pgweb.emile.space" = {
     forceSSL = true;
     enableACME = true;
 
     locations = {
       "/" = {
-        proxyPass = "http://127.0.0.1:5432";
+        proxyPass = "http://127.0.0.1:${toString ports.pgweb}";
       };
     };
   };