about summary refs log tree commit diff
path: root/nix/hosts/corrino/www/photo/photoprism.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/hosts/corrino/www/photo/photoprism.nix')
-rw-r--r--nix/hosts/corrino/www/photo/photoprism.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/nix/hosts/corrino/www/photo/photoprism.nix b/nix/hosts/corrino/www/photo/photoprism.nix
new file mode 100644
index 0000000..c1cbbf8
--- /dev/null
+++ b/nix/hosts/corrino/www/photo/photoprism.nix
@@ -0,0 +1,33 @@
+{ config, ... }:
+
+{
+  services.nginx.virtualHosts."photo.emile.space" = {
+    forceSSL = true;
+    enableACME = true;
+
+    locations = {
+      "/" = {
+        proxyPass = "http://127.0.0.1:${toString config.services.photoprism.port}";
+        proxyWebsockets = true;
+      };
+    };
+  };
+
+  services.photoprism = {
+    enable = true;
+
+    address = "127.0.0.1";
+    port = config.emile.ports.photo.photoprism;
+
+    passwordFile = config.age.secrets.photoprism_password.path;
+
+    # originalsPath = "/data/photos";
+    originalsPath = "/mnt/storagebox-bx11/photos";
+
+    settings = {
+      PHOTOPRISM_ADMIN_USER = "root";
+      PHOTOPRISM_DEFAULT_LOCALE = "en";
+      PHOTOPRISM_SITE_URL = "https://photo.emile.space";
+    };
+  };
+}