about summary refs log tree commit diff
path: root/nix/hosts/hacknix/pkgs/helix-2303/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/hosts/hacknix/pkgs/helix-2303/default.nix')
-rw-r--r--nix/hosts/hacknix/pkgs/helix-2303/default.nix18
1 files changed, 15 insertions, 3 deletions
diff --git a/nix/hosts/hacknix/pkgs/helix-2303/default.nix b/nix/hosts/hacknix/pkgs/helix-2303/default.nix
index bdbc112..eb54a90 100644
--- a/nix/hosts/hacknix/pkgs/helix-2303/default.nix
+++ b/nix/hosts/hacknix/pkgs/helix-2303/default.nix
@@ -1,4 +1,10 @@
-{ fetchzip, lib, rustPlatform, installShellFiles, makeWrapper }:
+{
+  fetchzip,
+  lib,
+  rustPlatform,
+  installShellFiles,
+  makeWrapper,
+}:
 
 rustPlatform.buildRustPackage rec {
   pname = "helix";
@@ -29,7 +35,10 @@ rustPlatform.buildRustPackage rec {
     };
   };
 
-  nativeBuildInputs = [ installShellFiles makeWrapper ];
+  nativeBuildInputs = [
+    installShellFiles
+    makeWrapper
+  ];
 
   postInstall = ''
     # not needed at runtime
@@ -50,6 +59,9 @@ rustPlatform.buildRustPackage rec {
     homepage = "https://helix-editor.com";
     license = licenses.mpl20;
     mainProgram = "hx";
-    maintainers = with maintainers; [ danth yusdacra ];
+    maintainers = with maintainers; [
+      danth
+      yusdacra
+    ];
   };
 }