about summary refs log tree commit diff
path: root/nix/hosts/mail/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/hosts/mail/hardware-configuration.nix')
-rw-r--r--nix/hosts/mail/hardware-configuration.nix29
1 files changed, 20 insertions, 9 deletions
diff --git a/nix/hosts/mail/hardware-configuration.nix b/nix/hosts/mail/hardware-configuration.nix
index 2653297..1ede4cd 100644
--- a/nix/hosts/mail/hardware-configuration.nix
+++ b/nix/hosts/mail/hardware-configuration.nix
@@ -1,22 +1,33 @@
 # Do not modify this file!  It was generated by ‘nixos-generate-config’
 # and may be overwritten by future invocations.  Please make changes
 # to /etc/nixos/configuration.nix instead.
-{ config, lib, pkgs, modulesPath, ... }:
+{
+  config,
+  lib,
+  pkgs,
+  modulesPath,
+  ...
+}:
 
 {
-  imports =
-    [ (modulesPath + "/profiles/qemu-guest.nix")
-    ];
+  imports = [ (modulesPath + "/profiles/qemu-guest.nix") ];
 
-  boot.initrd.availableKernelModules = [ "ata_piix" "virtio_pci" "virtio_scsi" "xhci_pci" "sd_mod" "sr_mod" ];
+  boot.initrd.availableKernelModules = [
+    "ata_piix"
+    "virtio_pci"
+    "virtio_scsi"
+    "xhci_pci"
+    "sd_mod"
+    "sr_mod"
+  ];
   boot.initrd.kernelModules = [ ];
   boot.kernelModules = [ ];
   boot.extraModulePackages = [ ];
 
-  fileSystems."/" =
-    { device = "/dev/disk/by-uuid/eccc47d3-7cee-4af5-822a-4ae0b302cb10";
-      fsType = "ext4";
-    };
+  fileSystems."/" = {
+    device = "/dev/disk/by-uuid/eccc47d3-7cee-4af5-822a-4ae0b302cb10";
+    fsType = "ext4";
+  };
 
   swapDevices = [ ];