about summary refs log tree commit diff
path: root/nix/lib/flake-helper.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/lib/flake-helper.nix')
-rw-r--r--nix/lib/flake-helper.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/nix/lib/flake-helper.nix b/nix/lib/flake-helper.nix
index cac3a71..2f8a020 100644
--- a/nix/lib/flake-helper.nix
+++ b/nix/lib/flake-helper.nix
@@ -194,13 +194,14 @@ rec {
     {
       remoteBuild = true;
       hostname = "${ip}";
-      fastConnection = true;
+      # fastConnection = true;
       profiles.system = {
         user = "root"; # user to install as
         sshUser = sshUser; # user to ssh to as
 
         # make sure people can use sudo 
         # sshOpts = ["-A", "-t", "-S"];
+        sshOpts = [ "-o"  "ProxyCommand=none" ];
 
         # make sure to add the nix foo on the darwin hosts to ~/.zshenv
         # as the ~/.zshrc doesn't get sourced when ssh-ing into the system