about summary refs log tree commit diff
path: root/nix/pkgs/r2wars-web/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/pkgs/r2wars-web/default.nix')
-rw-r--r--nix/pkgs/r2wars-web/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/nix/pkgs/r2wars-web/default.nix b/nix/pkgs/r2wars-web/default.nix
new file mode 100644
index 0000000..2e46665
--- /dev/null
+++ b/nix/pkgs/r2wars-web/default.nix
@@ -0,0 +1,31 @@
+{ pkgs, lib, fetchgit }:
+
+pkgs.buildGoModule rec {
+  name = "r2wars-web-${version}";
+  version = "0.1.0";
+
+  src = fetchgit {
+    url = "git://git.emile.space/r2wars-web.git";
+    hash = "sha256-n+La+C1diNCkxlGIxLu9nGQ//tJ5eDUjvXvdGP4Mdnk=";
+  };
+
+	vendorHash = null;
+  CGO_ENABLED=0;
+  subPackages = [ "src" ];
+
+  postInstall = ''
+    mkdir -p $out
+    cp -r templates $out
+
+    mv $out/bin/src $out/bin/r2wars-web
+  '';
+  
+  doCheck = false;
+
+  meta = {
+    description = "A golang implementation of r2wars";
+    homepage = "https://r2wa.rs";
+    license = lib.licenses.mit;
+    maintainers = with lib.maintainers; [ hanemile ];
+  };
+}