about summary refs log tree commit diff
path: root/nix/templates/ctf/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/templates/ctf/flake.nix')
-rw-r--r--nix/templates/ctf/flake.nix47
1 files changed, 26 insertions, 21 deletions
diff --git a/nix/templates/ctf/flake.nix b/nix/templates/ctf/flake.nix
index de6e2c1..67f33ca 100644
--- a/nix/templates/ctf/flake.nix
+++ b/nix/templates/ctf/flake.nix
@@ -7,7 +7,8 @@
   };
 
   # Flake outputs
-  outputs = { self, nixpkgs }:
+  outputs =
+    { self, nixpkgs }:
     let
       # Systems supported
       allSystems = [
@@ -20,28 +21,32 @@
       # Helper to provide system-specific attributes
       nameValuePair = name: value: { inherit name value; };
       genAttrs = names: f: builtins.listToAttrs (map (n: nameValuePair n (f n)) names);
-      forAllSystems = f: genAttrs allSystems (system: f {
-        pkgs = import nixpkgs { inherit system; };
-      });
+      forAllSystems = f: genAttrs allSystems (system: f { pkgs = import nixpkgs { inherit system; }; });
     in
     {
       # Development environment output
-      devShells = forAllSystems ({ pkgs }: {
-        default =
-          let
-            python = pkgs.python311; # Use Python 3.11
-          in
-          pkgs.mkShell {
-            packages = with pkgs; [
-              qemu
-            ] ++ [
-              # Python plus helper tools
-              (python.withPackages (ps: with ps; [
-                pwntools
-                pycryptodome
-              ]))
-            ];
-          };
-      });
+      devShells = forAllSystems (
+        { pkgs }:
+        {
+          default =
+            let
+              python = pkgs.python311; # Use Python 3.11
+            in
+            pkgs.mkShell {
+              packages =
+                with pkgs;
+                [ qemu ]
+                ++ [
+                  # Python plus helper tools
+                  (python.withPackages (
+                    ps: with ps; [
+                      pwntools
+                      pycryptodome
+                    ]
+                  ))
+                ];
+            };
+        }
+      );
     };
 }