about summary refs log tree commit diff
path: root/secrets.nix
diff options
context:
space:
mode:
Diffstat (limited to 'secrets.nix')
-rw-r--r--secrets.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/secrets.nix b/secrets.nix
index 1a625d3..67bf9b9 100644
--- a/secrets.nix
+++ b/secrets.nix
@@ -5,6 +5,12 @@
 
 # nix eval --impure --expr 'import ./secrets.nix'
 
+# As we're generating the secret.nix, we have a bootstrapping problem:
+# agenix assumes that the to be generated secret is present in the
+# secret.nix file, but we've not created it yet.
+# Due to this, we've got a "new" file in the secrets directory that can be used
+# and renamed afterwards
+
 let
 	pubkeysFor = directory:
 		let