about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorEmile <git@emile.space>2024-08-16 19:50:26 +0200
committerEmile <git@emile.space>2024-08-16 19:50:26 +0200
commit1a57267a17c2fc17fb6e104846fabc3e363c326c (patch)
tree1e574e3a80622086dc3c81ff9cba65ef7049b1a9 /default.nix
initial commit
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..dd888fa
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,18 @@
+{ pkgs ? import <nixpkgs> {}, lib }:
+
+pkgs.buildGoModule rec {
+  name = "r2wars-web-${version}";
+  version = "1.0.0";
+
+  src = ./.;
+	vendorHash = null;
+
+  CGO_ENABLED=0;
+
+  meta = {
+    description = "A golang implementation of r2wars";
+    homepage = "https://r2wa.rs";
+    license = lib.licenses.mit;
+    maintainers = with lib.maintainers; [ hanemile ];
+  };
+}