about summary refs log tree commit diff
path: root/nix/hosts/corrino/www/git/cgit.nix
diff options
context:
space:
mode:
authorEmile <git@emile.space>2024-09-29 00:02:29 +0200
committerEmile <git@emile.space>2024-09-29 00:02:29 +0200
commit080ae016d6b281f06404da05b1e69ea0ad706650 (patch)
treee409419dcf47f80922493afbd79620b7b7fccb42 /nix/hosts/corrino/www/git/cgit.nix
parent35e81755baf478c5505c2ac2c28188b17e583d5a (diff)
add cgit user to git group
Diffstat (limited to 'nix/hosts/corrino/www/git/cgit.nix')
-rw-r--r--nix/hosts/corrino/www/git/cgit.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/nix/hosts/corrino/www/git/cgit.nix b/nix/hosts/corrino/www/git/cgit.nix
index 4e4fe1a..ff60da3 100644
--- a/nix/hosts/corrino/www/git/cgit.nix
+++ b/nix/hosts/corrino/www/git/cgit.nix
@@ -33,6 +33,9 @@ in
     };
   };
 
+  # add the cgit user to the git group allowing them to read the git repos
+  users.groups."git".members = [ "cgit" ];
+
   services = {
     nginx.virtualHosts."git.emile.space" = {
       forceSSL = true;
@@ -42,8 +45,13 @@ in
     cgit.main = {
       enable = true;
       package = pkgs.cgit-pink;
+
+      user = "cgit";
+      group = "cgit";
+
       nginx.virtualHost = "git.emile.space";
       nginx.location = "/";
+
       repos = {
 
         # ops