about summary refs log tree commit diff
path: root/nix/hosts/corrino/www/git/cgit.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/hosts/corrino/www/git/cgit.nix')
-rw-r--r--nix/hosts/corrino/www/git/cgit.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/nix/hosts/corrino/www/git/cgit.nix b/nix/hosts/corrino/www/git/cgit.nix
index 4e4fe1a..ff60da3 100644
--- a/nix/hosts/corrino/www/git/cgit.nix
+++ b/nix/hosts/corrino/www/git/cgit.nix
@@ -33,6 +33,9 @@ in
     };
   };
 
+  # add the cgit user to the git group allowing them to read the git repos
+  users.groups."git".members = [ "cgit" ];
+
   services = {
     nginx.virtualHosts."git.emile.space" = {
       forceSSL = true;
@@ -42,8 +45,13 @@ in
     cgit.main = {
       enable = true;
       package = pkgs.cgit-pink;
+
+      user = "cgit";
+      group = "cgit";
+
       nginx.virtualHost = "git.emile.space";
       nginx.location = "/";
+
       repos = {
 
         # ops